Author Topic: The TBG Home Office Mini-ITX Build  (Read 22216 times)

Ari Altman

  • TBG Founder
  • Administrator
  • Hero Member
  • *****
  • Posts: 3019
    • View Profile
Re: The TBG Home Office Mini-ITX Build
« Reply #75 on: July 05, 2018, 06:22:41 PM »
Thanks for the info. 

A few questions about the wifi problem.

Was this try recent?  What version of ubuntu?  The reason that I ask is that later linux kernels may have the appropriate driver for your wifi.  I think that LM19 has the Linux kernel 4.15.0-20.  Drivers are packaged with the kernel.  You can "add" drivers but it is rarely needed.

BTW, you can get the latest Linux Mint at https://linuxmint.com/.  Download time for me is ~~10 minutes, then write to a 4GB or larger USB stick, and try it WITHOUT affecting your current install.  It might be an interesting project for you (or not)
See:
https://www.lifewire.com/create-uefi-bootable-linux-mint-usb-2202084                        to write to USB stick
https://www.zdnet.com/article/the-linux-mint-desktop-continues-to-lead-the-rest/        general info

It looks like Intel linux drivers are available for wifi
https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html

Do you know what the chipset is for the wifi that you were using in your ubuntu test?  I have not figured it out from amazon for your "base"  motherboard. It may be an Intel AC 9560?

This is probably not a problem, and probably not worth your time "putzing around" with it, but it might be interesting?

Thanks!
Ralph


NOTE: I was able to get everything working (including wifI) on all of these laptops and desktops using Linux Mint.  They may not have been "bleeding edge" tech, though.

My ubuntu test was on an older motherboard, probably 2 generations ago. One of the big new additions to the Intel-based B360/H370 boards is built-in support for WiFi (although it must be implemented by the manufacturer). That means this integrated Intel solution is going to become the reference WiFi going forward (and Intel probably was already), so I would go in assuming that the WiFi will work on Ubuntu today using new hardware.

RalphP

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: The TBG Home Office Mini-ITX Build
« Reply #76 on: July 05, 2018, 08:24:16 PM »
Thanks for the information and your opinion.  I am not much of a hardware guy.  I wrote software (Fortran, Basic, Lisp, C++, java) for many years.  So I appreciate it!

Ralph

dlott

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: The TBG Home Office Mini-ITX Build
« Reply #77 on: July 09, 2018, 09:40:38 PM »
The MX500 is supported by the motherboard - it's just newer than the board, which is why it isn't listed. The board will actually support any SATA M.2 drive.

OK, if a light is turning on, it clearly has power. What I'd suggest is unplugging the hard drive and seeing if the system will recognize the M.2 drive at that point. There could be an overlap between the SATA port you're using and the M.2 slot. There are limited SATA resources available on the chipset. If this works, just move the hard drive to another port.

If this doesn't work, you could have either a motherboard or SSD issue, and it will be pretty hard to tell which one it is. Replacing the SSD is obviously easier.

Just to close the loop here: I talked with Gigabyte support and they weren't really sure where the problem was.  They implied the MX500 was supported.  But on Crucial's site, they
explicitly say it's NOT compatible with the Gigabyte H370N Wifi http://www.crucial.com/usa/en/CT500MX500SSD4  Crucial suggests using the 2.5" version of the drive instead http://www.crucial.com/usa/en/h370n-wifi/CT12217200  Which I did since I didn't want to deal with the hassle and don't really have plans to use the second bay.

Ari Altman

  • TBG Founder
  • Administrator
  • Hero Member
  • *****
  • Posts: 3019
    • View Profile
Re: The TBG Home Office Mini-ITX Build
« Reply #78 on: July 10, 2018, 12:01:22 AM »
The MX500 is supported by the motherboard - it's just newer than the board, which is why it isn't listed. The board will actually support any SATA M.2 drive.

OK, if a light is turning on, it clearly has power. What I'd suggest is unplugging the hard drive and seeing if the system will recognize the M.2 drive at that point. There could be an overlap between the SATA port you're using and the M.2 slot. There are limited SATA resources available on the chipset. If this works, just move the hard drive to another port.

If this doesn't work, you could have either a motherboard or SSD issue, and it will be pretty hard to tell which one it is. Replacing the SSD is obviously easier.

Just to close the loop here: I talked with Gigabyte support and they weren't really sure where the problem was.  They implied the MX500 was supported.  But on Crucial's site, they
explicitly say it's NOT compatible with the Gigabyte H370N Wifi http://www.crucial.com/usa/en/CT500MX500SSD4  Crucial suggests using the 2.5" version of the drive instead http://www.crucial.com/usa/en/h370n-wifi/CT12217200  Which I did since I didn't want to deal with the hassle and don't really have plans to use the second bay.

M.2 drives are really pretty universal, so I'm not sure what Crucial is basing its determination that the MX500 won't work in the Gigabyte H370N WiFI board. You already confirmed that you are using the front slot, which is the one that's compatible with SATA devices like the MX500. Another forum reader just had a problem with another Gigabyte board and the MX500 drive, but it turned out he had used the PCIe-only slot. Since that doesn't apply to you, I honestly can't
 tell you what's wrong. I hesitate to believe that Crucial's determination is correct, as that would "break" the M.2 standard.

But in order for you to move ahead with your build, definitely feel free to get the 2.5" drive. It should absolutely work.  When I have time, I'll look further into what Crucial is concerned about with the Gigabyte board. Crucial actually says the drive is compatible with the Gigabyte B360N WiFi that is the current main recommendation for the build, which only has one M.2 slot (on the back). My guess is that Crucial is incorrectly analyzing the H370N based on its rear-mounted PCIe-only slot.

RalphP

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: The TBG Home Office Mini-ITX Build
« Reply #79 on: August 24, 2018, 01:18:14 PM »
Hi,

I built the Mini-ITX PC with some minor changes from the current suggested base-design.  I used an  I3-8100 CPU, Noctura cooler (so quiet!), 16 GB of RAM, 1 TB Seagate hard-drive and a 500 GB m.2 Crucial SSD.  Its a tight fit in the Antec Mini-ITX case, but not a problem.  (I used the standard GIGABYTE B360N WiFi motherboard).  This is my first build, so I had a few questions for my kids who have built several big desktops. 

The only "problem" that I have had is with the SSD drive which gets warm under major load (like a disk format to ext4 and then the system install).  The SSD is rated 0C - 70c and it hit a few peaks of 72C or so during the install.  Since then, I cranked up the fan-curve on the CPU for a bit more air-flow and drilled a bunch of small holes (~300) in the fake-grid on SSD side of the case.  The holes do not "show".  These 2 changes seem to help take the peaks off of the SSD temp.  I am currently running about 38C while browsing the web,....

I am running Linux Mint 19 (https://linuxmint.com/) and everything works perfectly!  All hardware is recognized and used.  The install to a "bare" system was trivial and it is extremely fast.  Questions about LM19 -- drop me a note!

Thanks for the article and your help!
Ralph

Ari Altman

  • TBG Founder
  • Administrator
  • Hero Member
  • *****
  • Posts: 3019
    • View Profile
Re: The TBG Home Office Mini-ITX Build
« Reply #80 on: August 24, 2018, 04:32:24 PM »
Glad to hear this worked out Ralph, others will definitely be interested in running Linux now that they've heard about your experience.